Back to overview
Resolved
Email sending is down
Aug 19, 2026 at 4:16pm UTC
Affected services
Email sending
Resolved
Aug 19, 2026 at 9:49pm UTC
We have resolved the issue and email sending is back up.
Will follow up with a post-mortem
Affected services
Updated
Aug 19, 2026 at 9:09pm UTC
Still working on a fix. Apologies for the delay please bear with us.
Affected services
Created
Aug 19, 2026 at 4:16pm UTC
We are investigating and working on a fix
Affected services