Back to overview
Resolved

Email sending outage post-mortem

Aug 20, 2026 at 12:07am UTC
Affected services
Email sending

Resolved
Aug 20, 2026 at 12:07am UTC

Email sending has recovered completely. All services are now healthy. We sincerely apologies for any disruption caused by the outage. We are committed to making sure such an incident does not occur in the future. Post-mortem linked below:

https://www.agentmail.to/incidents/2026-08-19-outbound-email-disruption