Back to overview
Degraded
Email receiving is down
Mar 19, 2026 at 2:24am UTC
Resolved
Mar 19, 2026 at 2:48am UTC
Email receiving recovered.
Affected services
Updated
Mar 19, 2026 at 2:46am UTC
Email receiving is degraded.
Affected services
Updated
Mar 19, 2026 at 2:29am UTC
Email receiving recovered.
Affected services
Created
Mar 19, 2026 at 2:24am UTC
Email receiving is degraded.
Affected services